Windows: impossibile applicare GPO, event id 1065

luca 31/08/2015 0

Oggi mi sono accorto che alcuni server Windows non applicavano più i GPO (Group Policy Objects) definiti nel dominio. Analizzando il problema, ho trovato nell’eventlog l’evento 1065:

gpo-wmi-1

Una delle GPO in effetti aveva applicato un WMI filter e il server, non essendo per qualche motivo in grado di valutare tale filtro, fermava tutto il processo di applicazione dei GPO.

Ho aperto la console di gestione WMI con il comando wmimgmt.msc:

gpo-wmi-2

e ho verificato che tutto il sottosistema WMI del server sembrava corrotto:

gpo-wmi-3

Per avere qualche dettaglio in più, ho scaricato l’utility WMIdiag dal sito Microsoft ed eseguito. Nel log ho trovato l’indicazione che lo stato del repository WMI era INCONSISTENT:

gpo-wmi-4

Per effettuare il rebuild completo del repository ho per prima cosa stoppato il servizio Windows Management Instrumentation, quindi ho rinominato la cartella Repository (in C:\Windows\System32\wbem) in Repository.old:

gpo-wmi-5

Ho quindi riavviato il servizio in modo che venisse creato un nuovo repository.

Per aggiungere anche le classi di terze parti presenti nel sistema, ho infine aperto un prompt dei comandi, mi sono spostato in C:\ e ho eseguito il comando:

for /f %%s in ('dir /s /b *.mof *.mfl') do mofcomp %%s

Dopo un riavvio, il server ha applicato correttamente le policy e il sottosistema WMI è tornato disponibile.

Leave A Response »

Questo sito usa i cookie per poterti offrire una migliore esperienza di navigazione maggiori informazioni

Questo sito utilizza i cookie per fonire la migliore esperienza di navigazione possibile. Continuando a utilizzare questo sito senza modificare le impostazioni dei cookie o clicchi su "Accetta" permetti al loro utilizzo.

Chiudi